Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: Transistor ou Relé?

Transistor ou Relé? 18 Jan. 2021 22:11 #1

  • almamater
  • Avatar de almamater
  • DESLIGADO
  • membro há mais de 7 anos
  • pt  
  • Mensagens: 73
  • Agradecimentos 2
Olá.

Preciso de controlar uma barra de leds (cerca de 40 leds), ligada diretamente aos 12V tenho um consumo de ~430mA.

Para controlar tenho um sinal lógico de 3.3V.

Inicialmente pensei num Relé de 12V controlado por um transistor (e com os 3.3V).

Hoje no entanto achei que com um Transistor fosse melhor (mais eficiente) mas não estou satisfeito com os resultados.

Testei com um transistor (BD139) ligado desta forma:
Transistor-s-val.png


Apenas existe um consumo de ~150mA (por parte de todo o circuito), ou seja, longe dos 430mA.

Testei depois com um P-Mosfet, usei o IRF9640 (-11A\-200V\0.50R):

multiple-leds.png





Mas aconteceu +- a mesma coisa, um consumo de 240mA, melhora mas não é o ideal.

Com o relé, obviamente são os 430mA certos, tem o contra de ser um pouco barulhento e ocupar mais espaço.


Pergunto assim, os resultados que tive com os transistores pode-se dever aos valores\especificações dos que escolhi ou na prática vou ter sempre uma 'quebra' na alimentação à barra de leds?

Ou os circuitos usados não estão bem?

Obrigado.
Última Edição: 18 Jan. 2021 23:18 por Rui. Motivo: colocação imagem diretamente no servidor

Transistor ou Relé? 18 Jan. 2021 22:56 #2

  • Divercentro
  • Avatar de Divercentro
  • DESLIGADO
  • membro com conhecimentos técnicos de electronicamembro há mais de 12 anos
  • pt  
  • Mensagens: 1431
  • Agradecimentos 265
3,3 volts é baixo

Experimente reduzir o valor da resistencia de base do transistor
Os seguintes utilizadores Agradeceram: almamater

Transistor ou Relé? 18 Jan. 2021 22:59 #3

  • zurca1599
  • Avatar de zurca1599
  • DESLIGADO
  • membro com conhecimentos técnicos de electronicamembro há mais de 12 anos
  • pt  
  • Mensagens: 6892
  • Agradecimentos 2524
No 1º circuito troque a resistência de 1k para 100 Ohm.
Os seguintes utilizadores Agradeceram: almamater, edremit

Transistor ou Relé? 18 Jan. 2021 23:08 #4

  • almamater
  • Avatar de almamater
  • DESLIGADO
  • membro há mais de 7 anos
  • pt  
  • Mensagens: 73
  • Agradecimentos 2
Ena!! Afinal era a resistência da Base.. com 100R de facto o consumo fica nos 432mA. Està perfeito ☺

Obrigado pelas respostas

Transistor ou Relé? 19 Jan. 2021 03:09 #5

  • zurca1599
  • Avatar de zurca1599
  • DESLIGADO
  • membro com conhecimentos técnicos de electronicamembro há mais de 12 anos
  • pt  
  • Mensagens: 6892
  • Agradecimentos 2524
Já agora , o segundo circuito funciona.
Deve ter feito alguma ligação incorrecta.

Transistor ou Relé? 19 Jan. 2021 23:05 #6

  • almamater
  • Avatar de almamater
  • DESLIGADO
  • membro há mais de 7 anos
  • pt  
  • Mensagens: 73
  • Agradecimentos 2
Peço desculpa por voltar a chatear mas não consigo descobrir uma solução para a 'nova' implementação que queria fazer ao circuito do Transistor BD139 que está a funcionar bem desta forma.

Queria colocar um LED que apenas ficasse ligado enquanto o Transistor estivesse Desligado. Quando houver 3.3.V no circuito o Transistor liga (tal como está) e o LED desligava (um LED ON apenas para quando o circuito está OFF).

Testei com um PNP, partilhando os mesmos 3.3V mas não consigo chegar a nenhuma solução.., existe alguma implementação simples que não esteja a ver para esta ideia?

Transistor ou Relé? 20 Jan. 2021 01:04 #7

  • zurca1599
  • Avatar de zurca1599
  • DESLIGADO
  • membro com conhecimentos técnicos de electronicamembro há mais de 12 anos
  • pt  
  • Mensagens: 6892
  • Agradecimentos 2524
Não sei o objectivo do que está a fazer mas experimente ligar uma resistência de 1k e um led 20ma em serie ente o colector do BD139 e o gnd.

Transistor ou Relé? 20 Jan. 2021 11:19 #8

  • almamater
  • Avatar de almamater
  • DESLIGADO
  • membro há mais de 7 anos
  • pt  
  • Mensagens: 73
  • Agradecimentos 2
Seria então desta forma:

Transistors_Without_Values.png


Quase que funcionava, acontece que o LED de facto acende quando a base do BD139 não tem tensão (3.3V) mas acontece que a minha "carga" que é também uma fita de leds acaba por acender, mesmo que com muito pouca intensidade.. :unsure:
Última Edição: 24 Jan. 2021 20:56 por Rui. Motivo: colocação da imagem a abrir diretamente no servidor

Transistor ou Relé? 20 Jan. 2021 17:41 #9

  • mjoao
  • Avatar de mjoao
  • DESLIGADO
  • membro com conhecimentos técnicos de electronicamembro há mais de 12 anos
  • pt  
  • Mensagens: 140
  • Agradecimentos 31
boa tarde, a corrente no colector emissor do transístor é relativo ao ganho do mesmo(ic=beta ib)

o seu caso era resolvido com um relais com o contacto repouso
a alimentar o piloto através de uma resistência

Transistor ou Relé? 20 Jan. 2021 20:20 #10

  • zurca1599
  • Avatar de zurca1599
  • DESLIGADO
  • membro com conhecimentos técnicos de electronicamembro há mais de 12 anos
  • pt  
  • Mensagens: 6892
  • Agradecimentos 2524
almamater escreveu:
Seria então desta forma:


Quase que funcionava, acontece que o LED de facto acende quando a base do BD139 não tem tensão (3.3V) mas acontece que a minha "carga" que é também uma fita de leds acaba por acender, mesmo que com muito pouca intensidade.. :unsure:

Eu sei disso. Mas se essa pequena luminosidade perturba o que quer fazer então acrescente um transístor 2N3904, por exemplo, com montagem idêntica ao do BD139.
Mas a resistência de base de 10k que vai ligar ao colector do BD 139.
No colector do 2N3904 liga o novo led em série com resistência de 560 Ohm.
Última Edição: 20 Jan. 2021 20:23 por zurca1599.
Os seguintes utilizadores Agradeceram: edremit

Pesquisar Esquemas | Dicas Defeito - Avarias | Equivalência Componentes | Modelo v Chassis | Service Mode |