Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: “Fenómeno” subida lenta de tensão c/ mosfet

“Fenómeno” subida lenta de tensão c/ mosfet 08 Nov. 2018 23:24 #1

Boa noite pessoal,
Estou ainda de volta de um pequeno projeto para a regulação de intensidade de uns leds...
Acontece que estou a usar um MOSFET STP16NF06L para regular entre 0-24V para os leds, como gate do mesmo estou a utilizar um sinal PWM que vem de um esp8266 ou Arduino.
Estou a presenciar um fenómeno estranho que devido ao meu baixo conhecimento não sei o porquê de acontecer nem como resolver.
Ao colocar o sinal pwm com uma saída suficiente que permita que a tensão dos leds esteja, por exemplo, a 17,40V reparo que em segundos a tensão vai subindo sozinha e ligeiramente passando para 17,41 / 17,42 e assim sucessivamente sendo que ao fim de uns bons minutos a diferença já se torna grande.
Alguém pode-me ajudar a perceber isto?
Muito obrigado e cumprimentos

“Fenómeno” subida lenta de tensão c/ mosfet 09 Nov. 2018 00:57 #2

  • zurca1599
  • Avatar de zurca1599
  • DESLIGADO
  • membro com conhecimentos técnicos de electronicamembro há mais de 11 anos top5 em número de mensagens
  • pt  
  • Mensagens: 6537
  • Agradecimentos 2344
De forma simples.
Do ponto de vista eléctrico a gate de um mosfet , com source comum , comporta-se como um condensador.

Desta forma e para que o mosfet funcione com sinal PWM tem de garantir que esse condensador (gate) seja carregado e descarregado COMPLETAMENTE.

Para isso é necessário que o circuito de drive da gate possa fornecer e absorver a corrente necessária nos tempos do sinal.

Se tal não acontecer pode ter o efeito que está a observar.
Última Edição: 09 Nov. 2018 00:58 por zurca1599.

“Fenómeno” subida lenta de tensão c/ mosfet 09 Nov. 2018 08:58 #3

zurca1599 escreveu:
De forma simples.
Do ponto de vista eléctrico a gate de um mosfet , com source comum , comporta-se como um condensador.

Desta forma e para que o mosfet funcione com sinal PWM tem de garantir que esse condensador (gate) seja carregado e descarregado COMPLETAMENTE.

Para isso é necessário que o circuito de drive da gate possa fornecer e absorver a corrente necessária nos tempos do sinal.

Se tal não acontecer pode ter o efeito que está a observar.

Bom dia e em primeiro lugar obrigado pela resposta.

Imaginei algo deste estilo pelo que consegui ler porque com um sinal analógico e estabilizado isto não acontece... Assim sendo como é que posso/devo resolver isto? Colocar alguma resistência antes da entrada na gate?

Obrigado

“Fenómeno” subida lenta de tensão c/ mosfet 09 Nov. 2018 21:52 #4

  • zurca1599
  • Avatar de zurca1599
  • DESLIGADO
  • membro com conhecimentos técnicos de electronicamembro há mais de 11 anos top5 em número de mensagens
  • pt  
  • Mensagens: 6537
  • Agradecimentos 2344
Isso só quem está a desenhar o circuito.
Genericamente precisa de drive correcto seja com integrado seja com circuito discreto.

Procure por "gate drive circuit for mosfet" .
Vai ter diferentes hipóteses e escolher a melhor para o que pretende.

Pesquisar Esquemas | Dicas Defeito - Avarias | Equivalência Componentes | Modelo v Chassis | Service Mode |