Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar
Eletronica Digital, Microcontroladores, Robótica e Automação

TÓPICO: PIC16F84A NÃO FUNCIONA

PIC16F84A NÃO FUNCIONA 04 Mar. 2019 13:59 #1

  • Bino
  • Avatar de Bino
  • DESLIGADO
  • membro com conhecimentos técnicos de electronicamembro há mais de 12 anos top20 em número de mensagens
  • pt  
  • Mensagens: 754
  • Agradecimentos 26
Ando a aprender a programar PICs, tenho visto vários vídeos no youtube e já fiz uns pequenos programas no micropascal para um PIC16F84A. Na simulação no proteus funcionam bem mas no circuito real não funcionam. Em princípio deverá ser alguma coisa mal configurada, mas não estou a ver o que seja. No circuito real estou a usar um cristal entre os pinos 15 e 16 e já experimentei com 4Mhz e 10Mhz mas não resulta. Como gravador estou utilizar o PICKIT3 o qual indica sempre que a gravação foi efetuada com sucesso, mas depois não dá nada. Alguém tem alguma dica?

Obrigado.

Bino.

PIC16F84A NÃO FUNCIONA 04 Mar. 2019 14:13 #2

  • Rui
  • Avatar de Rui
  • DESLIGADO
  • adminmembro há mais de 13 anos top5 em número de mensagens
  • pt  
  • Mensagens: 5560
  • Agradecimentos 1079
Coloque, se for possível, o circuito que está a usar para tentarmos perceber a origem do problema.

PIC16F84A NÃO FUNCIONA 05 Mar. 2019 23:42 #3

  • Bino
  • Avatar de Bino
  • DESLIGADO
  • membro com conhecimentos técnicos de electronicamembro há mais de 12 anos top20 em número de mensagens
  • pt  
  • Mensagens: 754
  • Agradecimentos 26
Este é o circuito com o PIC16F84. Quando se pressiona o botão A a primeira vez, acende o primeiro led. Se pressionar o botão A pela segunda vez, apaga o primeiro led e acende o segundo, e assim sucessivamente até o último led, ou seja, vai incrementando cada led. O botão B faz o mesmo, mas em sentido contrário, desincrementa.

Bino.
Anexos:

Pesquisar Esquemas | Dicas Defeito - Avarias | Equivalência Componentes | Modelo v Chassis | Service Mode |